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LI�ÌO 6: REUNINDO TUDO

OBJETIVOS

Nesta lição você aprenderá a:

• visualizar seu filme com o comando Test Movie
• exportar seu filme para um arquivo Shockwave Flash pronto para a Web
• usar o Macromedia Aftershock para colocar seu filme em uma página da Web

CONTEXTO

Agora que você completou sua primeira obra-prima animada no Flash, é hora de compartilhá-la com o

mundo. A maneira mais comum de fazer isso é exportar seu filme como um arquivo Shockwave Flash.

Você poderá, depois, colocar esse arquivo em uma página de seu site da Web para que os visitantes de

sua página consigam visualizar o filme. Os filmes Shockwave Flash preservam toda a animação e

interatividade do arquivo do filme original e, além disso, esse tipo de arquivo é bem pequeno e rápido de

ser transferido.

Depois de salvar seu arquivo como um arquivo Shockwave Flash, será preciso incorporá-lo a um filme

HTML. A Macromedia facilita isso com seu programa Aftershock, que acompanha a versão 3 do Flash. O

Aftershock criará páginas HTML com todos os códigos necessários para a execução do filme. Como

alternativa, você pode adicionar os filmes Shockwave Flash a uma página da Web usando qualquer pro-

grama de edição em HTML, mas provavelmente precisará conhecer um pouco do código HTML correto.

O Flash também permite a exportação de seu filme em outros formatos, como GIF animado ou vídeo

Quicktime.

EXERCêCIOS

EXPORTE SEU FILME

Antes de exportar seu filme, existem algumas coisas que você deve saber. Você pode usar o controle

Test Movie para verificar seu trabalho antes de fazer a exportação. 

Teste Seu Filme

1. Se seu filme “ant.fla” não estiver aberto, vá em frente e abra-o agora.
2. Escolha Control > Test Movie.
3. O Flash irá exportar o filme para um arquivo Shockwave Flash e, em seguida, abrir uma janela de

visualização. O tamanho da janela de visualização pode ser diferente da do filme original. Para
visualizá-lo em tamanho real, escolha View > 100%.

4. Você pode controlar a reprodução selecionando Window > Controller. Use o controlador como faria
normalmente para interromper ou iniciar a reprodução.
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5. Observe que as três cenas do filme estão sendo executadas: a primeira cena, que é um quadro fixo
simples, a cena Animation e a cena Marching Ants, que também é um quadro fixo simples. (Se
essas cenas de quadros simples forem executadas rápido demais para que você as perceba, não se
preocupe. Você conseguirá vê-las no procedimento 7 a seguir.) O Flash monta suas cenas em
seqüência dentro de um filme completo quando faz a exportação.

6. Se o filme ainda estiver sendo executado, selecione Control > Stop para interrompê-lo. 
7. Tente verificar o filme quadro a quadro. Selecione Control > Step Forward. Para repetir, use a 

tecla > do teclado.
8. Quando você atingir o último quadro do filme (as três formigas pequenas), selecione Control >

Rewind para retornar ao início.
9. Feche a janela Test Movie clicando na caixa fechar ou selecione File > Close.

Exclua Cenas Extras

O próximo passo é excluir a primeira e última cenas do filme. deixando somente a cena Animation para
exportar.

1. Clique na guia Scene 1.
2. Selecione Insert > Remove Scene. O Flash pedirá sua confirmação. Clique em OK.
3. Agora, clique na guia Marching Ants. Selecione Insert > Remove Scene e confirme clicando em OK.
4. Convém salvar uma cópia de todas as cenas que criou. Selecione File > Save As. Chame o arquivo

de “antmovie.fla” e clique em Save. O arquivo “antmovie.fla” será seu arquivo de filme final,
contendo somente uma cena. (O arquivo mais antigo, “ant.fla,” ainda contém a Scene 1 e a cena
Marching Ant. Se quiser, poderá retornar a esse arquivo no futuro.)

5. Selecione Control > Test Movie para ter certeza de que o filme está sendo executado de forma
apropriada. Você não verá mais a Scene 1 ou as Marching Ants. Feche a janela Test Movie quando
terminar.

Exporte um Arquivo Shockwave Flash

Agora você está pronto para exportar seu filme final para uma animação interativa pronta para a Web.

1. Selecione File > Export Movie.
2. Chame o arquivo de “antmovie.swf”. O formato deve ser Shockwave Flash. Pressione Save para

continuar.
3. A caixa de diálogo Export Shockwave Flash aparecerá (Figura 6-1). As opções controlam a

qualidade da imagem (Qualidade JPEG), qualidade do som (Audio Stream e Audio Event) e algumas
outras configurações. As configurações padrão devem funcionar bem neste filme. Consulte os
Tópicos da Ajuda do Flash para obter mais informações sobre a personalização dessas opções.

4. Clique em OK para terminar. O Flash irá, agora, exportar seu filme.

Figura 6-1
Estas configurações
controlam a qualidade da
imagem e do som do o seu
filme pronto para a Web.



PUBLICANDO NA WEB

O próximo passo na publicação de seu filme na Web é incorporá-lo a um documento HTML. Quando

fizer isso, haverá uma série de configurações especiais que controlarão o modo de exibição de seu

filme. Essas configurações incluem: se o filme entra em loop, seu tamanho na janela do navegador, a

qualidade da imagem e assim por diante. Embora seja possível definir manualmente essas opções em

um programa de edição HTML, o programa Aftershock incluído no Flash 3 facilita o processo. Ele

também acrescenta algumas dicas interessantes para ajudar os usuários da Web que talvez não

possuam o software necessário para visualizar o filme do Flash.

Usando o AfterShock

1. Abra o Aftershock. Ele deve ser instalado na mesma unidade em que você instalou o Macromedia
Flash.

2. Selecione File > Add > Shockwave.
3. Localize o arquivo “antmovie.swf” e o selecione. Clique em Abrir. O filme da formiga será

adicionado ao painel Files da janela Aftershock.
4. O painel Settings do lado direito oferece várias opções para controlar o modo como seu filme será

exibido na página da Web. Clique na guia Scripting para iniciar.

Otimizando Seu Filme para a Web

Se você já navegou na World Wide Web, sabe como é importante descarregar e exibir
rapidamente as páginas da Web. Quanto menor o tamanho do arquivo, mais rápida será a
transferência para o navegador da Web de seus usuários. Felizmente, o Flash foi desenvolvido
para resolver essa questão. Seu formato de arquivo baseado em vetores gera arquivos pequenos,
que podem ser descarregados rapidamente a partir de sua página Web. Além disso, o Flash tem
um formato streaming, o que significa que seu filme pode começar a ser executado enquanto o
arquivo está sendo descarregado.

Existem algumas estratégias que podem ser adotadas para reduzir ainda mais o tamanho do
arquivo de filme. Entre ela se incluem:

• Sempre que possível, use símbolos para elementos que aparecem mais de uma vez.

• Agrupe elementos onde possível.

• Use animações em modo tweening; elas são muito mais eficazes que as animações quadro
a quadro.

• Use a opção Optimize Curves para reduzir o número de segmentos de linha e de pontos de
sua imagem.

• Simplifique suas imagens gráficas e cores. Bitmaps, degradês, cores personalizadas e tipos
especiais de linhas aumentam o tamanho do arquivo.

• Menos é mais. Use poucos bits de som e trabalhe com o menor número possível de fontes e
estilos diferentes.

É possível experimentar diferentes configurações e estratégias para agilizar os tempos de transfe-
rência. Use os controles Test Movie para visualizar a aparência que seu filme terá para usuários
com modems mais lentos. Além disso, verifique o tamanho final dos arquivos exportados.
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5. As configurações da guia Scripting controlam o que acontecerá se um usuário desejar executar seu
filme mas não possuir o software necessário. 

Para executar um filme Shockwave Flash em um navegador da Web (como o Netscape Navigator ou
o Microsoft Internet Explorer), os usuários precisam ter instalado o plug-in Shockwave Flash em
seus computadores. Esse plug-in pode ser obtido de graça no site da Macromedia na Web. As
configurações de script informarão ao navegador o que fazer se esse plug-in não estiver
imediatamente disponível.

Por enquanto, deixe as opções da guia Scripting como configurações padrão. A opção Static ou
Animated GIF deve ser selecionada. Essa opção apresentará uma imagem GIF como alternativa ao
filme do Flash, se necessário. (Um GIF é um arquivo de imagem padrão que será exibido de forma
fácil na maioria dos navegadores da Web.)

6. Em seguida, clique na guia Page Layout. Esse painel controla o local em que o filme do Flash será
colocado e seu tamanho na página da Web. Observe que o Aftershock fez a leitura das dimensões
que você definiu anteriormente na caixa de diálogo Movie Properties no Flash. 
Como exercício, configure seu filme para ser executado na metade do tamanho original. Digite
“275” dentro da caixa Width (Largura) e “200” dentro da caixa Height (Altura). Observe que isso
não vai alterar o tamanho do filme em si; ele altera somente o tamanho em que será exibido nesta
página da Web em particular.

Deixe as outras opções com as configurações padrão.

7. Clique na guia Shockwave. Estas opções permitem um controle maior sobre o modo como o filme é
executado.

Como você já conseguiu que seu filme entrasse em loop com uma ação de quadro, cancele a
seleção da opção Loop. A opção Paused At Start aguardará uma entrada do usuário antes de
executar o filme. Não a deixe selecionada para fazer com que o filme comece a ser executado
imediatamente. É possível alterar a cor de fundo da página HTML e do filme, se você quiser.

8. Clique na guia Alternate Image. Se você selecionou Static ou Animated GIF nas configurações da
guia Scripting anteriormente, precisará decidir que imagem GIF será criada para os usuários que não
conseguirem executar seu filme Shockwave Flash. Você pode escolher um GIF estático de quadro
único ou um GIF animado, que exibirá parte de seu filme todo como uma imagem animada. O GIF
animado não terá a interatividade ou som do filme original.

Para este exemplo, selecione Static GIF. Do lado esquerdo do painel Settings, use as setas Frame
para clicar em cada quadro do filme e selecionar o quadro que ficará bem como uma única imagem
fixa. O quadro 14 pode ficar bom. Altere as dimensões de cada GIF para combinar àquelas que você
definiu nas opções Page Layout: 275 por 200 pixels.

Selecione as opções Interlace e Smooth. 

9. A guia Java contém mais alguns recursos avançados. Você pode pular essa guia por enquanto.
10. Você esta pronto para criar a página HTML do filme. Selecione File > Save.
11. Chame o arquivo de “antmovie.html”. O tipo de arquivo deve ser HTML.



12. Clique no botão Salvar para finalizar. O Aftershock salvará o arquivo HTML, exportará uma imagem
GIF e, em seguida, abrirá seu navegador da Web (se encontrar um) para visualizar sua nova página
da Web. Você pode abrir o arquivo “antmovie.html” em qualquer editor HTML e alterá-lo
posteriormente.

Parabéns! Você acaba de completar o processo de construção de uma animação interativa e de sua
transformação em uma página da Web. Te vejo na Web.

MAIS EXERCÍCIOS PARA APRIMORAR SUAS HABILIDADES

• Reveja a lista de dicas para otimizar filmes para a Web. Quais dessas dicas você usaria em
seu filme? Sugestão: você provavelmente poderia usar várias dessas dicas na camada Sun.
Vá em frente e experimente algumas delas.

•Usando o Aftershock, salve diferentes versões da página do filme como antmovie1.html,
antmovie2.html e assim por diante. Experimente configurações diferentes do Aftershock para
ver como elas afetam o filme.

• Se você possuir um programa de edição de páginas da Web, como o Dreamweaver, HomeSite
ou BBEdit, abra o arquivo antmovie.html criado com o Aftershock. Reveja o código HTML para
aprender mais sobre as marcas apropriadas para os filmes Shockwave Flash.

• Para obter mais informações sobre como exportar filmes do Flash para outros formatos,
consulte os tópicos da Ajuda do Flash.
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Figura 6-2
A janela Aftershock,
com configurações
para uma imagem
GIF estática
alternativa. O
quadro do filme
mostrado aqui será
exibido para
usuários da Web que
não conseguem
visualizar seu filme
do Flash.



CURRÍCULO DO FLASH

OBSERVA�ÍES:

36


